The AZ CTE LTI Tool is currently incompatible with Safari 13+. We recommend using the LTI with Chrome or Firefox while we work to fix this. We apologize for the inconvenience.


Content Selection

The LTI tool allows any educator to browse and embed media objects alongside other content within assignments, or select content which comprises entire modules, lessons, or units. All users are able to search content added to CTE Curriculum Connection Collections. Additionally, users can also browse or search content from Group Shared Folders and personal My Items libraries, if that content has been configured and made available. 

Authentication and Account Provisioning

The tool provides automated authentication and new account provisioning, providing users with an "SSO like" experience. The LTI key/secret pair can also be configured to automatically add new users to an CTE Curriculum Connection Group. 

LTI Tool Preview Images

Some basic preview images of the tool have been included below. More details about using the LTI tool are available in the "Using the LTI tool" section of this guide.  

This is a screenshot showing what browsing CTE Curriculum Connection Collections looks like in the LTI tool.

This is a screenshot showing what browsing My Items looks like in the LTI tool.

This is a screenshot showing what browsing Group folders looks like in the LTI tool.

Getting Set up in Blackboard

Get Your LTI Credentials 

Contact for your LTI Credentials 

If you would like to configure access to a specific CTE Curriculum Connection Group you have created, please specify that in your email.   

Installing and Configuring the App in Blackboard

Add CTE Curriculum Connection LTI tool provider

  1. On the Administrator Panel, select LTI Tool Providers.

  2. Configure Provider Domain Status

    1. Enter in the Provider Domain textbox.

    2. Set Provider Domain Status to “Approved”

  3. Default Configuration

    1. Select “Set Globally”

    2. Enter the Key and Secret you received from

  4. Configure Institution Policies

    1. Select “Send User Data only over SSL”

    2. User Fields to send should include Role in Course and Email Address 

      1. *Note: If you don’t allow sending email address you will need to manually log in with a username and password every time you use CTE Curriculum Connection. 

  5. Click “Submit” 

Add CTE Curriculum Connection LTI Placement

  1. From the LTI Tool Providers page, open the Tools menu and select “Manage Placements”

  2. Select “Create Placement”

  3. Configure Placement Information

    1. Enter a Label. This is the name that appears to users in a course.

    2. Enter a Handle. This must be a unique ID for the tool which can only contain alphanumeric, underscore, or dash characters. 

    3. Set Availability to “Yes”

    4. Set Tool Type to “Content Type” tool

    5. Select “Build Content (Create)” 

  4. Configure Tool Provider Information

    1. Enter the Launch URL you received from  in the Tool Provider URL input box

    2. Enter the Key and Secret you received 

    3. Click “Submit” 

Troubleshooting and Technical Documentation

Check your Cookie Settings  

  1. Make sure you are allowing third-party cookies. We use a cookie to connect your Blackboard session to your CTE Curriculum Connection session. If you don't allow third-party cookies, we won't be able to connect your sessions and log you in.  

  2. Make sure  has been added to your allowed sites if you are strict about your cookie settings 

You can refer to the links below for more information about managing cookies in different browsers. 

Manage Cookies in Chrome

Manage Cookies in Firefox

Manage Cookies in Safari

Manage Cookies in IE

Safari SSO Issue

If you are using Safari 13+ the solution below will not work, due to updates with the way 3rd party cookies are handled.  We recommend using Firefox or Chrome instead. 


If you are using Safari 12 or earlier:

The Problem: I am using Safari and I can’t seem to login to the LTI Tool no matter what I do! I’ve even tried changing my password via reset password from email, and it still doesn’t work. 

The Solution: 

  1. Check your cookie settings, and make sure you are allowing third-party cookies. If you are strict about your cookie settings, you may need to whitelist 

  2. Close out of the LTI Tool

  3. Open the Homepage in a new tab 

  4. Launch the LTI tool again 

The Reason

Safari does a lot to protect your privacy, and ensure third parties aren’t tracking you without your consent. Because of this, Safari won’t allow third parties to set cookie information if it looks like you haven’t visited the site recently. This means we can’t set an SSO cookie if you’ve recently cleared your history, are using Safari for the first time, or are using Safari on a new device. Opening the CTE Curriculum Connection Homepage will fix this problem because it indicates to Safari that CTE Curriculum Connection is a site you use intentionally. Technical details can be found here:

Other Technical Documentation

The CTE Curriculum Connection LTI Tool Provider conforms to the IMS LTI 1.1 Standard:

We also support Content Item Message Extension, or Deep Linking:

Required Parameters

The following parameters must be present in LTI launch request sent by the Tool Consumer

  • One of the following content identification parameters:

a.) resource_link_id (alphanumeric GUID)

b.) custom_redirect_url (full URL pointing to content on the CTE Curriculum Connection platform, used in manual config only)

  • tool_consumer_instance_guid

  • role

  • email

  • userid

*If parameters do not conform exactly to the parameters listed above, the LTI tool will return a missing parameter error.

Optional Parameters

  • launch_presentation_return_url

If this parameter is present it will be used to redirect a user when a resource is selected in the picker interface. Otherwise, the user is redirected to the specified CTE Curriculum Connection content page.

Error Messages

If the cause of the error is known, the LTI tool will return an error message with debugging information. The most common cause of errors is missing LTI parameters.